[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] device-mapper ioctl interface version 3



On Tuesday 29 April 2003 11:03, Alasdair G Kergon wrote:
> On Tue, Apr 29, 2003 at 10:50:49AM -0500, Kevin Corry wrote:
> > My only question is: shouldn't the ioctl version be increased to 4.0.0?
>
> Version 3 hasn't officially been released yet: none of our releases
> have had major version 3 - the only people with it would be people
> playing with development versions, and I see no need to retain
> compatibility with these - or we'd be on at least version 20 by now!
>
> Or has EVMS already released packages with a version 3?

Well, yes. :) Based on the discussions we had last month, I was under the 
impression that the 3.0.0 version would be released as it was originally 
proposed (see the thread at 
http://lists.sistina.com/pipermail/dm-devel/2003-March/000107.html). So we 
went ahead and updated EVMS to use that version.

> If so, we probably do need to up it to 4!
>
> Alasdair

I guess the choice is up to you. If you'd like to stay with 3.0.6, I can 
simply add a check in EVMS 2.0.x to only work with version 3.0.0 of the 
interface. Future versions of EVMS (2.1, etc) will hopefully be updated to 
work with the latest DM.

On a somewhat related note: the Device-Mapper CVS tree has seen a lot of 
activity in the last month, whereas in the past (say, Dec to March 
timeframe), most development updates/bug-fixes were done through patchsets on 
Joe's website. Are we still going to see the occasional patchset tarballs, or 
will the CVS tree now be the primary location for development versions of DM?

-- 
Kevin Corry
kevcorry us ibm com
http://evms.sourceforge.net/




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]