[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] Why it can not support more than 100 targets in 1 MD ?

Kevin Corry wrote:
On Thursday 01 April 2004 20:46, Ji Haitao wrote:

I create a MD having 100 targets with dmsetup. IO error occurs when I
access the 100th target. My operation steps are :

1.#create md
sh> dmsetup create vd1 dmtable1

#access the 100th target
sh> dd bs=512 count=10 if=/dev/zero of=/dev/mapper/vd1 seek=51380224

#errors happen
dd: writing `/dev/mapper/vd1': Input/output error
1+0 records in
0+0 records out

I ran your 100-target table on one of my systems. Did a dd of the entire device with no I/O errors. I'm running device-mapper.1.00.08 on a 2.6.5-rc3 kernel.

If I only have 99 targets in dmtable1, everything is OK when I access
the 99th target. Why? If device-mapper can support more than 100 targets
in 1 MD ?

The configuration of my Linux host is:
CPU: P4 1.4G
MEM: 512M
Kernel: 2.4.21
dd (fileutils) 4.1.9

1.00.05 is a bit out-of-date. I'd suggest upgrading to device-mapper.1.00.09 (upgrade both the tools and the kernel patches) and see if the problem persists.

Thank Kevin Corry very much!

I upgraded my device-mapper from 1.00.05 to 1.00.09 and everything is OK now.

I did more tests and verified that device-mapper.1.00.09 can support more than 204,800 linear targets on a linux host with 128M RAM and work well. When I tried to add 2,048,000 targets, dmsetup told me the memory was not enough, but device-mapper did not crash. I think this is OK.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]