[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] dmsetup on uClibc based system

On Friday 19 March 2004 9:46 am, Kevin Corry wrote:
> On Thursday 18 March 2004 6:45 pm, Pete Flugstad wrote:
> >      The command appears to have worked, but the entry in /dev/mapper is
> > not there.
> >
> >       Does dmsetup not work on partitions?  Or is this probably something
> > else going on?  Does it matter if the partition in question is mounted?
> Actually, it does matter. You won't be able to activate a DM device on a
> partition that contains a mounted filesystem (2.6 kernels don't allow
> that).

To be more specific...

You can create the DM device, because device creation in DM doesn't 
necessarily imply that the device contains an active mapping. What you cannot 
do (on 2.6 kernels) is load a table into that device that uses a partition 
with a mounted filesystem.

Thus, the creation portion of your command worked, but the table-loading 
portion failed, which is why you see hdc5.000 in "dmsetup ls".

Kevin Corry
kevcorry us ibm com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]