[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] Multipath setup


I'm trying to use the multipath software in my project. I downloaded and

installed the 2.6.12.rc2-odm1 (I turned on the Multi-Device
Mapper Support and Multipath I/O Support)

I also download and install the mutipath-tools 0.4.4. But when I tried 

[root dhcp76 multipath-tools-0.4.4]# ./multipath/multipath
device mapper prerequisites not met

I don't known what's wrong with it. I ran dmsetup

[root dhcp76 multipath-tools-0.4.4]# /sbin/dmsetup targets
striped          v1.0.2
linear           v1.0.1
error            v1.0.1

Is that mean I don't have multipath support compiled in the kernel ?

Also, I have a generic question regarding to the multipath tool. We ran
virtualization softwares, which generate different UUID (SCSI VPD 83)
for the 
same LUN go through different path, can the multipath software config
two LUNs with difference UUID in a multipath setup ?

Best regards

Xiaowen Wu
Software Engineering
Xiaoweu Wu hds com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]