[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] [PATCH] multipath-tools/kpartx - loop support



On Thu, Sep 29, 2005 at 02:52:16PM +0100, Alasdair G Kergon wrote:
> On Thu, Sep 29, 2005 at 03:17:23PM +0200, Bastian Blank wrote:
> > Use kernel definition of __kernel_old_dev_t.
> 
> That only works if your glibc-kernheaders package defines it 
> and not all do, which is why it's there.

It breaks the rule to not use the libc supplied linux headers anyway. On
the otherside, the correct dev_t definition is supplied by
linux/types.h for versions which have no selfcontaining linux/loop.h.

>                                           The story seems 
> to be that that package lags behind the kernel because people don't 
> update glibc immediately every time something is added to the kernel.

The glibc headers are supposed to match the kernel it is built against.

> So while it's OK to remove it for some distributions, you can't
> remove it upstream.

With the linux/types.h include it should work for the headers from linux
>= 1.3.78, it this old enough? Without it seems to be okay for 2.6.

Bastian

-- 
Earth -- mother of the most beautiful women in the universe.
		-- Apollo, "Who Mourns for Adonais?" stardate 3468.1

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]