[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] multipath v0.4.5, nodes not appearing in /dev/

multipath version: multipath v0.4.5 (16/06, 2005)
kernel: Linux 2.6.9-22.ELsmp #1 SMP Mon Sep 19 18:32:14 EDT 2005
os: Red Hat Enterprise Linux ES release 4 (Nahant Update 2)


Im new to multipath/devicemapper, so please excuse any misterminology or misunderstanding on my part : )

Basically, if i start up the multipathd service and run multipath to scan for devices, it finds (as it's supposed to) and emc entry (which i defined in /etc/multipath.conf).

[root cc1-86 dev]# multipath -v2 -l
emc1 (36006016046861000625964d94cbbd911)
[size=133 GB][features="0"][hwhandler="1 emc"]
\_ round-robin 0 [active]
  \_ 1:0:0:0 sdb  8:16    [active]
  \_ 2:0:0:0 sdd  8:48    [active]
\_ round-robin 0 [enabled]
  \_ 1:0:1:0 sdc  8:32    [active]
  \_ 2:0:1:0 sde  8:64    [active]

[root cc1-86 dev]#

Now, originally we were running a previous version as a seperate admin mentioned here: https://www.redhat.com/archives/dm-devel/2005-August/msg00043.html , after lots of back and forth for this and other issues, our redhat support instructed us to use a updated version of multipath (ver listed above). back on the previous version (v0.4.4), i would be able to find the multipath node in /dev so that i could mount it. but now, i dont see anything in /dev, i do however see entries in /dev/mapper:

[root cc1-86 dev]# ls -l /dev|grep dm
brw-r-----  1 root   root   253,   0 Sep 29 13:11 dm-0
[root cc1-86 dev]# ls -l /dev/mapper/
total 0
crw-------  1 root root  10, 63 Sep 29 09:08 control
brw-rw----  1 root disk 253,  0 Sep 29 13:11 emc1
[root cc1-86 dev]#

I've tried searching online for info, and i ran across this via http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=FAQ :

5. I see my multipath nodes in /dev/mapper/ but not in /dev/

Verify you have a naming rule configured in udev *and* no bypass rule for dm-* devices.
The naming rule may use dmsetup or multipath-tools'-provided devmap_name.

# Commented out :
# KERNEL="dm-[0-9]*", OPTIONS+="ignore_device"
KERNEL="dm-[0-9]*", PROGRAM="/sbin/devmap_name %M %m", NAME="%k", SYMLINK="%c"

Partition mapping through kpartx won't work unless devices appear in /dev/.

Can someone tell me if this is what I need to do as well? If so, where would this file be located, so that I can update it?

Thanks in advance,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]