[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [dm-devel] 4k block LUN problem

I didn't partition the dm device. I used fdisk to create the sda[1]
partition on the lun. The dm device is then created on sda[1]. I then
simply mkfs on the dm partition.  

I'll check again following your advice below with lvm and check with
blockdev. We are a bit new at this and information from reliable sources
is hard to come by (many opinions, less factual advice). Thanks for your
insight, I'll give it go.  


-----Original Message-----
From: dm-devel-bounces redhat com [mailto:dm-devel-bounces redhat com]
On Behalf Of Alasdair G Kergon
Sent: Wednesday, June 13, 2007 2:35 PM
To: device-mapper development
Subject: Re: [dm-devel] 4k block LUN problem

On Wed, Jun 13, 2007 at 03:17:25PM -0400, Vassar, Bob wrote:
> I have used tur and this allows the system to boot. When I run "ll
> /dev/mpath* I see the dm device created. All appears to be working OK.

So use tur then.  First problem solved.

> Fdisk also reports the same number of devices as paths to the device.

Fdisk?  Don't partition it: use logical volumes instead:
- You'd need parted (gpt) rather than fdisk to partition large devices
and then kpartx.

Now run 'blockdev --getss' to check whether or not the sector size gets
propagated correctly from the underlying device to the multipath device.

agk redhat com

dm-devel mailing list
dm-devel redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]