[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

R: [dm-devel] - info about dm

Dear Philip, Sean and all,

First of all I apologize for what I wrote: I recognize that's not

However at the moment I cannot reproduce the error because I solved the
issue through a workaround and I (stupid) didn't save any log of that.

Instead of trying to explain better what I wrote (in a mess!!!), can you
explain how to work with dmraid? Is there any official HowTo?
Man pages don't give us a step by step procedure and that's what I need

Some info about the machines:
HW: IBM x306 - 2 HD 160GB SATA - Adaptec HostRAID ASR (onboard)

# dmraid -tay
cl->raidtype=1 rd_type=64
cl->raidtype=1 rd_type=64
cl->raidtype=1 rd_type=64
cl->raidtype=1 rd_type=64
asr_: 0 312580096 mirror core 2 131072 nosync 2 /dev/sda 0 /dev/sdb 0
asr_1: 0 71681967 linear /dev/mapper/asr_ 63
asr_2: 0 4096575 linear /dev/mapper/asr_ 71682030
asr_3: 0 236798100 linear /dev/mapper/asr_ 75778605

# dmraid -r
cl->raidtype=1 rd_type=64
cl->raidtype=1 rd_type=64
/dev/sda: asr, "asr_", mirror, ok, 312580096 sectors, data@ 0
/dev/sdb: asr, "asr_", mirror, ok, 312580096 sectors, data@ 0

# dmsetup status
asr_p1: 0 71681967 linear 
asr_: 0 312580096 mirror 2 8:0 8:16 2385/2385 1 AA 1 core
asr_p3: 0 236798100 linear 
asr_p2: 0 4096575 linear 

# dmsetup ls
asr_p1  (253, 1)
asr_    (253, 0)
asr_p3  (253, 3)
asr_p2  (253, 2)

Let's handle a couple of doubts I have:

1) I need to change an HD which has problems...here the steps I guess
from what I read in these days:
- halt the machine (ok, ok it's obvious ;-P )
- change the faulty HD
- boot
- when BIOS starts the RAID manager, enter and rebuild the RAID (1:
- after the rebuilding, everything should be ok.

...is it correct?

2) I have a machine with 2 HD SATA, on the first we have the OS
installed (and working!), the second is blank (just added), I want to
create a RAID 1 (mirror) of the whole disk:
- ...
I don't want to guess ;-P

I know how to manage grub for booting from the new device, but I'm not
sure how to create such device...

Any tip is welcome!

Cheers and thanks

-----Messaggio originale-----
Da: dm-devel-bounces redhat com [mailto:dm-devel-bounces redhat com] Per
conto di Phillip Susi
Inviato: lunedì 12 novembre 2007 22.16
A: dm-devel redhat com; ataraid-list redhat com
Oggetto: Re: [dm-devel] - info about dm

Luca Berra wrote:
>> Anyway, I found a little problematic configuring it manually: I tried
>> install SL5 on a node which was misconfigured: instead of seeing one
>> device, it was managing the 2 HD (/dev/sda and /dev/sdb) as 2

This is as expected.  The hardware is just a sata controller with two 
disks attached, so that is what the kernel sees.  dmraid is used to 
recognize the bios information on the disk and configure the device 
mapper driver to create a raid virtual device.

>> devices an if I tried to configure them (at install time, via CD or
>> network boot) with  DM, I got many errors about the RAID table
>> asr: Invalid RAID config table checksum on /dev/sda” or even “asr:
>> Invalid magic number in RAID table; saw 0x0 expected…”). I tried to
>> reconfigure the RAID card first via BIOS and then trying again to
>> configure it via Linux (“dmsetup create …”) but even if it seemed

dmsetup create creates a new dm device.  Generally this command is for 
debugging and testing, so you should not use it.  It has nothing to do 
with dmraid other than they are both clients of the device mapper kernel


>> working (exit code 0), then querying the device asr_ (i.e. “dmraid
>> resulted in errors as reported above…or better, dmraid commands (-r,
>> -ay, -tay,…) reported errors, while dmsetup commands  (status, ls,…)

What where the exact commands and errors the generated?

I am also confused because the first thing you said was that the system 
DID correctly recognize the raid array as /dev/mapper/asr_xxxx.

>> 2) Managing disks
>> I configured disks in RAID 1 (mirror) but I wonder how to manage this
>> RAID; in particular, how can I do for:
>> - stopping a device (disk) and put it offline/and viceversa? - 
>> reconfiguring/rebuilding it (due to broken/faulting HD)?
>> At the moment I should change a couple of disks (SMARTD warnings
>> reported), but I’m scared about the “RAID table error”…

Currently the only way is to do so in the bios.  Some systems the bios 
will begin rebuilding when you tell it to, and you need to wait for it 
to finish.  On others, it only marks the disk as needing rebuilt and 
relies on the windows driver to do the rebuilding.  Currently dmraid 
does not perform rebuilding.

dm-devel mailing list
dm-devel redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]