[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] how to flush device with no paths but no_path_retry=queue



This seems to work fine when you issue dmsetup while there are IO's
pending.  However I recently tried this on a RHEL 4 update 5 system and
have run into at least one scenario where it does not work well.  If I
set the device to fail using dmsetup and then IO's are issued (that
fail) it seems that multipathd will try to "fix" the configuration and
place it back to queue.  I can then reissue the dmsetup to set it to
fail and the IO's fail.

I am not sure if this is an issue with the older multipath in RHEL 4.  I
don't believe I saw this issue with my earlier testing but perhaps I did
not try this scenario.

Eddie

On Fri, 2007-11-02 at 13:01 -0700, Mike Anderson wrote:
> Eddie Williams <Eddie Williams steeleye com> wrote:
> > 
> > If you have a device configured with no_path_retry=queue but you can not
> > repair the connections is there any way to flush the IO's?  
> > 
> > I can not find a way to force the device offline so that it will
> > flush/fail all of the pending IO's so I can shutdown or clean up the
> > mess.
> > 
> > Is there a way?
> 
> There maybe a cleaner way, but you should be able to do:
> 	dmsetup message ${device} 0 fail_if_no_path
> 
> It worked on my test config, but it was a pretty simple config.
> 
> -andmike
> --
> Michael Anderson
> andmike linux vnet ibm com
> 
> --
> dm-devel mailing list
> dm-devel redhat com
> https://www.redhat.com/mailman/listinfo/dm-devel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]