[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] multibus / failover and EMC CX600

* Gerald Nowitzky

> The mpath_prio_emc with group_by_prio did the trick. Thanks!
> But I am still loosing the paths to the failed devices. I Increased
> dev_loss_tmo, but the maximum seems to be about 600 - thus, after 10
> Minutes, the paths fail:

The maximum is indeed 600 seconds in 2.6.23.

> SANfile_m linux # multipath -l
> hcfshare (360060160c820080063502869e459dc11) dm-0 ,
> [size=3.4T][features=1 queue_if_no_path][hwhandler=1 emc]
> \_ round-robin 0 [prio=0][enabled]
>  \_ #:#:#:# -   #:#   [failed][undef]
>  \_ #:#:#:# -   #:#   [failed][undef]
> \_ round-robin 0 [prio=0][active]
>  \_ 2:0:0:0 sdd 8:48  [active][undef]
>  \_ 1:0:0:0 sdb 8:16  [active][undef]
> If I put them online again, I run into the -EEXIST prob. Async SCSI
> scanning *is* off in my kernel, so the only thing I could do from
> here is to try the patch, is it?

Matthew Wilcox' patch solved this particular problem for me, yes.  I
still had some problems with -EEXIST when unloading and re-inserting the
HBA driver module, though, but that's a corner case I rarely run into
(as well as being easily worked around by trying again).

Come to think of it, you never said which kernel version you're running...?

> Oct 17 17:26:36 SANfile_m kernel: kobject_add failed for 1:0:1:0 with
> -EEXIST, don't try to register things with the same name in the same
> directory.

One suggestion...  If the sysfs object is still around, you might be
able to delete it manually by running «echo 1 >
/sys/class/scsi_device/1:0:1:0/device/delete».  If that works, you can
try to rescan again by doing «echo 0 1 0 >
/sys/class/scsi_host/host1/scan».  With some luck it'll work...

If it does, most of the time udev will notice and alert multipath to
check out the new device.  Sometimes it doesn't work, though - simply
run the «multipath» command manually in that case.

By the way - the «1» in «host1» maps to the first digit in «1:0:1:0»,
while the «0 1 0» in the echo command to the last three.

Tore Anderson

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]