[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] Configuring multipath for root device

Hi All,

Thanks for all your comments, it worked for installaions on partitions.

Now the question is:
Is it supposed to work the same way if the SLES is installed on LVM?
On SLES, under fstab, I do not see any device, except for the boot
device; other entries does not have /dev/deisk mention. In such
scenario, how am I supposed to make the /root device multipath-aware?

I tried the same with RHEL, but with RHEL installed (with linux mpath)
on LVM, it seems to be working fine. Is there anything I am missing on

Thanks and Regards,

On Jan 7, 2008 11:17 PM, Hannes Reinecke <hare suse de> wrote:
> Pradipmaya Maharana wrote:
> > RHEL Steps worked perfectly for me but i have a question for SLES installation.
> >
> > Question. While installing SLES on multipath devices, the second step says:
> >
> > " 2. Complete the installation. Let the system boot up in multiuser mode.
> > Make sure the root device, swap device are all referenced by their by-id
> > device node entries instead of /dev/sd* type names. If they are not, fix
> > them first."
> >
> > How do you check that root device and swap device are referenced by their by-id?
> > And if it is not referenced by the by-id, how do I fix it? Re-install?
> >
> Check /etc/fstab. Those devices should be listed as /dev/disk/by-id/XXX.
> If not (ie if their names are /dev/sdXX) look for the appropriate symlink
> in /dev/disk/by-id and edit /etc/fstab.
> Cheers,
> Hannes
> --
> Dr. Hannes Reinecke                   zSeries & Storage
> hare suse de                          +49 911 74053 688
> SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
> GF: Markus Rex, HRB 16746 (AG Nürnberg)
> --
> dm-devel mailing list
> dm-devel redhat com
> https://www.redhat.com/mailman/listinfo/dm-devel

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]