[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [dm-devel] Multipath and getuid_callout issues with HP XP1024disk array



Ok, some more background first:

System is an HP Proliant DL380 (or maybe DL580?), using Emulex fibre
channel cards (don't know exact model off-hand).

Running Red Hat Enterprise Linux 4, update 5.

Device-mapper-multipath was version 0.4.5-21, just updated it to
0.4.5-27

There are 4 LUNs from an HP XP1024 disk array, each pathed to be visible
on each fibre channel.  LUN type is OPEN-E.
 
Multipath now seems to accept the longer string returned by scsi_id, but
it doesn't seem able to tell that certain disks are the same.

Attached is the multipath.conf file I'm using and the output from
"multipath -v3". If the attachments don't come through, I'll send
separate emails with just the contents for each file.

Any aide gladly received, I'm in over my head on this one.

Thanks,
Rick


-----Original Message-----
From: dm-devel-bounces redhat com [mailto:dm-devel-bounces redhat com]
On Behalf Of malahal us ibm com
Sent: Tuesday, January 29, 2008 5:19 PM
To: dm-devel redhat com
Subject: Re: [dm-devel] Multipath and getuid_callout issues with HP
XP1024disk array

Greene, Rick [rick greene ncogroup com] wrote:
>    I've done what I can to try to understand how all this works, but I
keep
>    getting "error calling out /sbin/scsi_id -g -u -s /block/sda" when
I run
>    the command "multipath -v2"
> 
> 
> 
>    I've tried a number of different things in the /etc/multipath.conf
file,
>    but keep coming back to this same error.  If I run the command
manually I
>    get the following:
> 
> 
> 
>    # /sbin/scsi_id -g -u -s /block/sda
> 
>    0HP______OPEN-E__________50060e80039c5a0400000000000000000000e100
> 
> 
> 
>    What's missing?  Any help greatly appreciated.

You are not missing anything. The device id is too big to fit in
multipath tools allocated memory. The program incorrectly prints that
there is a problem while executing /sbin/scsi_id but in fact the problem
lies in the program itself. You may have some old version of multipath
tools. WWID_SIZE was set to 64 bytes and that is small for your device.
Get the latest version where that macro is set to 128 or so.

Hope that helps!

--Malahal.

--
dm-devel mailing list
dm-devel redhat com
https://www.redhat.com/mailman/listinfo/dm-devel

Attachment: multipath.out
Description: multipath.out

Attachment: multipath.conf
Description: multipath.conf


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]