[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] multipath: expected results of configuring "no_path_retry"?

Diedrich Ehlerding wrote:
> I have a question concerning the expected behavior of dm_multipath 
> connected to an EMC Clariion array. Different versions of multipath 
> give different results when I disconnect all pathes to the storage. 
> I have one server (SuSE SLES10 SP2,, multipath-tools 
> 0.4.7-34.43) and another one (SLES 11,, 0.4.8-
> 40.1). Both versions recognize the Clariion without further setting in 
> multipath.conf. The settings for the Clariion in multipath -t seem to 
> be the same (especially queue_if_no_path + no_path_retry 60)
> Trying to setup a software mirror on top, i.e. trying to mirror the 
> data into a second box, I observed the follwoing diffenrent behavior 
> between these two versions: 
> - on the SLES10 machine, disconnecting the disk in one Clariion results 
> in IO error, the mirror breaks up, and the use IO continues on the 
> surviving part of the mirror. This is the behavior which I want, and 
> which I expected, and this was my understanding of "no_path_retry" - 
> retry some times, then terminate IO.  
> - on the SLES11 machine, the same attempt makes IO hang infinitely. The 
> messages display that all pathes fail, and then "Entering recovery 
> mode: max_retries=60" - but then, nothing happens; IOs hang.
Yes, I know. You are triggering Novell bugzilla #485281

Patch is already available from my multipath repository

branch sles11

Will be included in the next maintenance update.


Dr. Hannes Reinecke		      zSeries & Storage
hare suse de			      +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Markus Rex, HRB 16746 (AG Nürnberg)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]