[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] multipathd segfault and error calling out



John A. Sullivan III wrote:
On Wed, 2009-02-25 at 22:04 -0500, Konrad Rzeszutek wrote:
On Wed, Feb 25, 2009 at 09:07:44PM -0500, John A. Sullivan III wrote:
Hello, all.  I am running on kernel 2.6.27 on CentOS 5.2 with VServer
and device-mapper-multipath-0.4.7-17.el5.  I have a custom
mpath_prio_ssi script which takes the device name (e.g., sdaa), pulls
out the path from /etc/disk/by-path and then echos a priority based upon
a lookup table.  It works perfectly fine from the command line.
multipath -ll shows the priorities assigned perfectly and exactly the
right paths are active.

However, when I start multipathd, it all goes down the tubes.  The paths
disappear and /var/log/messages is filled with:
Feb 25 20:50:17 vd01 multipathd: error calling out /usr/local/sbin/mpath_prio_ssi sdh
Keep in mind that the environment you have when multipathd calls is quite
limited. I believe there is no PATH set, nor any other "normal" values.

Make sure your code uses absolute paths. So "/bin/grep" ,"/bin/cut", etc..
<snip>
Thank you.  I was enthusiastic that might have been the problem, but
alas not. Even with absolute pathnames and setting the PATH variable, it
still gives the same error.  In fact, I should have mentioned, I created
a bogus file with the same pathname which did nothing but "echo hello"
and it gave the same error calling out error.  What next? - John
Return an explicit exit code. It might be that eg 'cut' returns a non-zero
value, which then would interpreted as a failure.

Cheers,

Hannes
--
Dr. Hannes Reinecke		      zSeries & Storage
hare suse de			      +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Markus Rex, HRB 16746 (AG Nürnberg)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]