[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] question about output of dmsetup status



I’ve been experimenting a bit with dmraid eventing, and I notice that when I do the following, the result is not what I expect – but perhaps someone can enlighten me on what is truly expected:

 

  1. Setup a RAID0+1 with dmraid
  2. Register the RAID using dm_dso_reg_tool. I also ensure that it is properly registerd using “dm_dso_reg_tool –m”.
  3. I note the major and minor number of the devices that comprise the RAID, using “dmsetup status”.
  4. I start a write onto the RAID volume using a large file (3GB).
  5. During the write process, I pull one of the RAID member disks out so that I may simulate a RAID failure.
  6. I notice that the “dmsetup status” command shows one of the disks as being marked disabled – which is good. I take note of the disabled disk’s major:minor numbers.
  7. I reconnect the RAID member disk that I pulled out in step 5. When I look for that disk’s major:minor numbers using “ls –l /dev/sd*”, I don’t see that major:minor number pair.
  8. When I run “dmsetup status” again, the major:minor numbers for the pulled disk is still the same as the one I saw in Step 3.

 

What I expected was that the major:minor number pair for the pulled disk would correspond to the one that I saw in Step 7. Is my assumption incorrect? The reason why I was expecting it this way was because I was thinking that if I use dmsetup to determine the RAID status and see a disabled drive, I can follow it back to a /dev/sd* and then get the hard drive’s serial number – then I would know which member disk to replace. Is there a better way?

 

Thanks for clarifying,

Sandra


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]