[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] [PATCH 1/2] block: export __make_request

On Mon, Sep 12, 2011 at 08:04:46PM +0200, Jens Axboe wrote:
> > I really hate naming things different from the method they are
> > implementing.  I've tried to figure out what the point of the
> > old blk_make_request is - why would we not go through
> > generic_make_request for this?
> > 
> > Boaz, any idea?
> I tend to agree, we could rename the existing blk_make_request(). It
> could be blk_make_request_from_bio() or something like that, since
> that's what it does.

It should at very least be renamed.  But I still can't figure out what
it is for exactly.

There are three users:

 (1) virtio_blk::virtblk_get_id():
	This looks like it really should just use blk_rq_map_kern.
 (2) osd_initiator::_make_request():
	This one looks like it should just use the same scheme as
	sg_io(), as it's doing the same thing.
 (3) target_core_pscsi::__pscsi_map_SG():
	Same as (2).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]