[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] [PATCH 1/2] dm-crypt: Properly handle extra key string in initialization



On Mon, Oct 28, 2013 at 11:21:03PM +0100, Milan Broz wrote:
> +			cc->key_extra_size = cc->key_size / cc->key_parts;

I don't understand the logic that leads to this assignment.

Are there some implicit constraints on the input?

Do all invalid inputs produce an appropriate error?

Is there a clearer way to set out the calculation and can it be annotated?

Can we rename key_extra_size to extrakey_size (like subkey_size)?

Is extrakey_size always less than subkey_size?

Alasdair


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]