[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] v3.15 dm-mpath regression: cable pull test causes I/O hang

On 06/27/14 15:33, Mike Snitzer wrote:
> (we've seen sync on last close cause problems when the block device
> isn't reachable).
> Any other threads that look suspect in output from?:
>  echo t > /proc/sysrq-trigger

I have attached the echo w > /proc/sysrq-trigger output since that's the
only output I had saved. I have been analyzing the SysRq-t output but I
haven't found any additional clue in that output.

> Can you provide your dmsetup table output for the relevant mpath device?
> Are you using queue_if_no_path?  Also, AFAIK you don't use
> multipath-tools, but if by some chance you do please provide your
> multipath.conf.  I'll attempt to reproduce.

The test I ran was a fio data verification test on top of a dm device.
multipathd was running during this test. Is multipath.conf sufficient ?
I have attached my multipath configuration file to this e-mail.



Attachment: multipath-lockup-v3.16-rc2.txt.xz
Description: application/xz

defaults {
	polling_interval	1
	queue_without_daemon	no
	features		"3 queue_if_no_path pg_init_retries 50"
	path_grouping_policy	group_by_prio
blacklist {
	device {
		vendor	"ATA"
		product	"*"
devices {
	device {
		vendor			FUSIONIO
		product			"*"
		features		"3 queue_if_no_path pg_init_retries 50"
		#hardware_handler	"1 alua"
		#prio			alua
		#failback		followover
		path_checker		tur
		path_selector		"queue-length 0"
		#path_selector		"round-robin 0"

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]