[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2003:094-01] Updated MySQL packages fix vulnerabilities



---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Updated MySQL packages fix vulnerabilities
Advisory ID:       RHSA-2003:094-01
Issue date:        2003-04-28
Updated on:        2003-04-28
Product:           Red Hat Enterprise Linux
Keywords:          mysql
Cross references:  
Obsoletes:         RHSA-2002:289
CVE Names:         CAN-2003-0073 CAN-2003-0150
---------------------------------------------------------------------

1. Topic:

Updated packages are available that fix both a double-free security
vulnerability and a remote root exploit security vulnerability found in the
MySQL server.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux ES version 2.1 - i386
Red Hat Enterprise Linux WS version 2.1 - i386

3. Problem description:

MySQL is a multi-user, multi-threaded SQL database server.

A double-free vulnerability in mysqld, for MySQL before version 3.23.55,
allows attackers with MySQL access to cause a denial of service (crash) by
creating a carefully crafted client application.

A remote root exploit vulnerability in mysqld, for MySQL before version
3.23.56, allows MySQL users to gain root privileges by overwriting
configuration files.

Previous versions of the MySQL packages do not contain the thread safe
client library (libmysqlclient_r).

All users of MySQL are advised to upgrade to these errata packages
containing MySQL 3.23.56.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

Please note that this update is available via Red Hat Network.  To use Red
Hat Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/bugzilla for more info):

85898 - double-free vulnerability in mysqld < 3.23.55
85971 - possible root exploit in mysqld startup
77662 - mysql RPM's do not provide a thread safe library

6. RPMs required:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm

i386:
Available from Red Hat Network: mysql-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-server-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-devel-3.23.56-1.72.i386.rpm

ia64:
Available from Red Hat Network: mysql-3.23.56-1.72.ia64.rpm
Available from Red Hat Network: mysql-server-3.23.56-1.72.ia64.rpm
Available from Red Hat Network: mysql-devel-3.23.56-1.72.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm

ia64:
Available from Red Hat Network: mysql-3.23.56-1.72.ia64.rpm
Available from Red Hat Network: mysql-server-3.23.56-1.72.ia64.rpm
Available from Red Hat Network: mysql-devel-3.23.56-1.72.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm

i386:
Available from Red Hat Network: mysql-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-server-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-devel-3.23.56-1.72.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm

i386:
Available from Red Hat Network: mysql-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-server-3.23.56-1.72.i386.rpm
Available from Red Hat Network: mysql-devel-3.23.56-1.72.i386.rpm



7. Verification:

MD5 sum                          Package Name
--------------------------------------------------------------------------
54f783324c224840fe7ea702fe628ec2 2.1AS/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm
d1efdb7796e0444302ee3f426ca06c85 2.1AS/en/os/i386/mysql-3.23.56-1.72.i386.rpm
9b77319f6ecc7e5431efc99e7a291334 2.1AS/en/os/i386/mysql-devel-3.23.56-1.72.i386.rpm
ef3c7d3e1bfe3b835ee07b8d2eda7e21 2.1AS/en/os/i386/mysql-server-3.23.56-1.72.i386.rpm
fcdac19a133fcf7feb34e06877ed1242 2.1AS/en/os/ia64/mysql-3.23.56-1.72.ia64.rpm
6d5ed02bee3fe571275b5053cebc6c94 2.1AS/en/os/ia64/mysql-devel-3.23.56-1.72.ia64.rpm
19737a4c7f39bd37fbd73d0388d2c847 2.1AS/en/os/ia64/mysql-server-3.23.56-1.72.ia64.rpm
54f783324c224840fe7ea702fe628ec2 2.1AW/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm
fcdac19a133fcf7feb34e06877ed1242 2.1AW/en/os/ia64/mysql-3.23.56-1.72.ia64.rpm
6d5ed02bee3fe571275b5053cebc6c94 2.1AW/en/os/ia64/mysql-devel-3.23.56-1.72.ia64.rpm
19737a4c7f39bd37fbd73d0388d2c847 2.1AW/en/os/ia64/mysql-server-3.23.56-1.72.ia64.rpm
54f783324c224840fe7ea702fe628ec2 2.1ES/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm
d1efdb7796e0444302ee3f426ca06c85 2.1ES/en/os/i386/mysql-3.23.56-1.72.i386.rpm
9b77319f6ecc7e5431efc99e7a291334 2.1ES/en/os/i386/mysql-devel-3.23.56-1.72.i386.rpm
ef3c7d3e1bfe3b835ee07b8d2eda7e21 2.1ES/en/os/i386/mysql-server-3.23.56-1.72.i386.rpm
54f783324c224840fe7ea702fe628ec2 2.1WS/en/os/SRPMS/mysql-3.23.56-1.72.src.rpm
d1efdb7796e0444302ee3f426ca06c85 2.1WS/en/os/i386/mysql-3.23.56-1.72.i386.rpm
9b77319f6ecc7e5431efc99e7a291334 2.1WS/en/os/i386/mysql-devel-3.23.56-1.72.i386.rpm
ef3c7d3e1bfe3b835ee07b8d2eda7e21 2.1WS/en/os/i386/mysql-server-3.23.56-1.72.i386.rpm


These packages are GPG signed by Red Hat for security.  Our key is
available at http://www.redhat.com/solutions/security/news/publickey/

You can verify each package with the following command:
    
    rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    
    md5sum <filename>


8. References:

http://www.mysql.com/doc/en/News-3.23.55.html
http://www.mysql.com/doc/en/News-3.23.56.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0073
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0150

9. Contact:

The Red Hat security contact is <security redhat com>.  More contact
details at http://www.redhat.com/solutions/security/news/contact/

Copyright 2003 Red Hat, Inc.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]