[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2010:0102-01] Important: flash-plugin security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: flash-plugin security update
Advisory ID:       RHSA-2010:0102-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2010-0102.html
Issue date:        2010-02-12
CVE Names:         CVE-2010-0186 CVE-2010-0187 
=====================================================================

1. Summary:

An updated Adobe Flash Player package that fixes two security issues is now
available for Red Hat Enterprise Linux 5 Supplementary.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

RHEL Desktop Supplementary (v. 5 client) - i386, x86_64
RHEL Supplementary (v. 5 server) - i386, x86_64

3. Description:

The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash
Player web browser plug-in.

This update fixes two vulnerabilities in Adobe Flash Player. These
vulnerabilities are summarized on the Adobe Security Advisory APSB10-06
page listed in the References section. If a victim loaded a web page
containing specially-crafted SWF content, it could cause Flash Player to
perform unauthorized cross-domain requests, leading to the disclosure of
sensitive data. (CVE-2010-0186, CVE-2010-0187)

All users of Adobe Flash Player should install this updated package, which
upgrades Flash Player to version 10.0.45.2.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network.  Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

563819 - CVE-2010-0186 flash-plugin: unauthorized cross-domain requests (APSB10-06)
564287 - CVE-2010-0187 flash-plugin: possible player crash (APSB10-06)

6. Package List:

RHEL Desktop Supplementary (v. 5 client):

i386:
flash-plugin-10.0.45.2-1.el5.i386.rpm

x86_64:
flash-plugin-10.0.45.2-1.el5.i386.rpm

RHEL Supplementary (v. 5 server):

i386:
flash-plugin-10.0.45.2-1.el5.i386.rpm

x86_64:
flash-plugin-10.0.45.2-1.el5.i386.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-0186.html
https://www.redhat.com/security/data/cve/CVE-2010-0187.html
http://www.redhat.com/security/updates/classification/#important
http://www.adobe.com/support/security/bulletins/apsb10-06.html

8. Contact:

The Red Hat security contact is <secalert redhat com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFLdYE+XlSAg2UNWIIRAsL4AJkB2m7gjB+gxxFQ9WRKz7RTSE4NHgCgkn/q
HMgQlRzQ/G20AGJj8nxzX4Q=
=31YX
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]