[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum update problem on CentOS 5



Since I added the EPEL repository to my CentOS 4.5 system I've been
having trouble with 'yum update'.  It reports:

--> Running transaction check
--> Processing Dependency: perl-libxml-enno >= 1.02 for package: foomatic
--> Processing Dependency: perl(XML::RegExp) for package: perl-XML-DOM
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-XML-RegExp.noarch 0:0.03-2.el4 set to be updated
--> Running transaction check
--> Processing Dependency: perl-libxml-enno >= 1.02 for package: foomatic
--> Finished Dependency Resolution
Error: Missing Dependency: perl-libxml-enno >= 1.02 is needed by package foomatic

I can make it work either by disabling the EPEL repo (yum --disablerepo=epel
update) or by specifying explicitly what needs to be updated (yum update
tetex).  But I shouldn't have to.

Apparently perl-XML-DOM (from EPEL) obsoletes perl-libxml-enno <= 1.02,
but CentOS has perl-libxml-enno-1.02-31 which is required by foomatic.

Result misery.

Ron


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]