[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFP: octave and octave-forge for EL5



On Fri, Mar 09, 2007 at 06:53:01PM -0500, Philip Ray Schaffner wrote:
> On Thu, 2007-03-08 at 19:15 +0100, Patrice Dumas wrote:
> > On Thu, Mar 08, 2007 at 11:39:33AM -0500, Phil Schaffner wrote:
> > > 
> > > libdap-3.7.2-3.fc7.src.rpm
> > > libnc-dap-3.6.2-5.fc7.src.rpm
> > 
> > libnc-dap API/ABI is stable, but libdap is very unstable, and I am not
> > convinced that it is a right candidate for EPEL. I will discuss that
> > with upstream, however.
> 
> OK - put please consider the context.  No libdap, no octave-forge.

libdap API/ABI changes every 6 months, only the latest is maintained. 
In the case of that package I have very good relations with upstream, 
but I am not familiar enough with C++, the internal of libdap and
binary compatibility to be able to readd the removed interfaces or
backport critical fixes. If you (or anybody else) are volunteering to 
do that I'll happily do the packaging, but I cannot realistically 
commit to do it.

I do consider the context of EPEL.

I'll contact upstream, maybe now that there is a need for a more stable 
API they'll be willing to change their development model, but I cannot
make any promise.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]