[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mock 0.8.9 for EPEL-5



On Tue, Nov 20, 2007 at 11:45:12PM +0200, Manuel Wolfshant wrote:
> On 11/20/2007 11:42 PM, Michael E Brown wrote:
> >
> >If there is a large contingent of people running mock on EL-4, I would
> >be happy to update mock on EL-4 to latest if there is A) demand, and B)
> >somebody who is willing to test and (possibly) submit patches if there
> >are issues.
>    I do not know how many people run mock in EL-4 / Centos 4, but I 
> will be more than happy to help you testing. Maybe I also learn a bit of 
> python with this occasion...

So, so save you a bit of work, I went ahead and looked into this.

There is only one major problem with running mock 0.8.x on EL4, and that
is decorators. I use the new decorator syntax to instrument most
functions for logging and that decorator syntax is not available on
python 2.3 in EL4.

There is a way to modify the code to keep the functionality of the
decorators and still have backwards compatibility, but it isnt too
pretty. (Not that, bad, either...).

If you want to send me a patch, I would accept it, as long as it is
sane.
--
Michael


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]