[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 5.1 -> 5.2 move

Patrice Dumas wrote:
On Fri, Jun 06, 2008 at 04:55:28PM -0400, Bill Nottingham wrote:
Patrice Dumas (pertusus free fr) said:
Obssoletes:     gtkhtml3 < 3.12.1

But I may very well be missing something.
Not sure you want to Obsolete it, depending on where you're placing
the package.

But, if not Obsoleting, it won't be updated?

The old gtkhtml3 package will be updated by the new one ...

The compat-gtkhtml3 package should get installed IF something still needs the older library (libgtkhtml-3.8.so.15). BUT ... I don't want this compat package to REPLACE the older package, only be installed IF REQUIRED when the newer gtkhtml3 is installed.

In CentOS, this should not be a problem as the older version will be in the 5.1 tree and will not available when the upgrade takes place.

Also * maybe the devel package is not needed?
It's a different ABI - you can still develop against the old one
(as it does actually take some porting, and depending on what you
link against, porting may not be possible.)

I figured we may as well have the devel file to since the headers are named differently, just in case someone needs to compile against the older version and it may be that the code does not work with the newer version.

Indeed, but avoiding breaking ABI is very important, but for API it is
less improtant since users have time to port. But indeed it is even

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]