[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 5.1 -> 5.2 move



On Fri, Jun 06, 2008 at 07:53:52PM -0500, Johnny Hughes wrote:
>>
>> But, if not Obsoleting, it won't be updated?
>
> The old gtkhtml3 package will be updated by the new one ...

Indeed.

> The compat-gtkhtml3 package should get installed IF something still  
> needs the older library (libgtkhtml-3.8.so.15).  BUT ... I don't want  
> this compat package to REPLACE the older package, only be installed IF  
> REQUIRED when the newer gtkhtml3 is installed.

But in this case user compiled programs not instéalled as rpm packages
will be broken.

> I figured we may as well have the devel file to since the headers are  
> named differently, just in case someone needs to compile against the  
> older version and it may be that the code does not work with the newer  
> version.

Indeed, and especially if it is easy to do it is better to have compat
devel package.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]