[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken dependencies in EPEL 5 with CentOS 5 - 2008-10-26



On Sun, 26 Oct 2008 09:04:12 -0500, Rex Dieter wrote:

> Michael Schwendt wrote:
> 
> > package: 1:koffice-libs-1.6.3-16.el5.i386 from fedora-epel-testing-5-x86_64
> >   unresolved deps:
> >      libpython2.4.so.1.0
> 
> Is python not multilib'd here (EL-5/x86_64)?

The python-libs split in Fedora has been done in the Python 2.5 era.
EL 5 is older (Python 2.4).

> What to do about that?
>
> Blacklist koffice(-lib/devel) to not multilib?

As a last resort.

The file in koffice-libs, which requires libpython, is it needed for
compiling with koffice-devel? If the answer is "yes", there is no solution
other than blacklisting koffice-devel (and anything which requires it).

> Or, just inhibit the 
> generation of the -devel subpkg on EL-5 would do the same I guess.

Yes, no -devel pkg, and it won't be pulled in during multilib resolving.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]