[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

new perl package needs newer versions of dependancies.



Hello...

  I am trying to add a new perl Yahoo-Marketing module package to
fedora/epel, https://bugzilla.redhat.com/show_bug.cgi?id=524698. One of
the dependencies is for perl-Test-Class.  The current fedora package
requires newer versions of several existing modules.

from koji scratch build:
https://koji.fedoraproject.org/koji/getfile?taskID=1693325&name=build.log


+ /usr/bin/perl Build.PL installdirs=vendor
 - ERROR: Test::More (0.62) is installed, but we need version >= 0.78
 - ERROR: perl (5.008008) is installed, but we need version >= 5.6001
 - ERROR: Test::Builder (0.32) is installed, but we need version >= 0.78
 - ERROR: Test::Simple (0.62) is installed, but we need version >= 0.78
ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation
Checking whether your kit is complete...
Looks good
Checking prerequisites...
Creating new 'Build' script for 'Test-Class' version '0.31'


What is the general consensus on updating EPEL perl modules as
requirements for other perl modules?  Yes?  maybe?  never?  maintainers
choice?




-- 
Christopher McCrory
 "The guy that keeps the servers running"
 
chrismcc pricegrabber com
 http://www.pricegrabber.com
 
Let's face it, there's no Hollow Earth, no robots, and
no 'mute rays.' And even if there were, waxed paper is
no defense.  I tried it.  Only tinfoil works.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]