[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EPEL Packages in need of building for EL-6



Paul Howarth wrote:

>> Owner: pghmcfc
>> gtkwave
> 
> Current versions of gtkwave that I'd like to build in EL-6 use the Judy
> array library, which is not yet in EPEL. I wrote to the maintainer some
> time ago about this but haven't seen a response. The version of the
> library in Fedora isn't recent either, so perhaps the maintainer is
> AWOL. Haven't had time to investigate that yet.

Current EPEL branching policy seems to be put in a request for the
branch against the Fedora package, if there's no response within a week
or so then make the CVS Change Request and reference the ticket.

>> perl-Text-SpellChecker
> 
> This is built on Text::Aspell, which in turn is built on aspell. Whilst
> aspell is included in EL-6, it's only there for the purposes of building
> the hunspell dictionaries and there are no aspell dictionaries available
> (#590700). I think the way forward here is to bring aspell-en (at least)
> into EPEL-6. I don't know if the aspell-en maintainer is willing to do
> that themselves yet. 

The question of packages like this has come up, the optional repos seem
a little haphazard if you don't realise that much of what's in there is
to support BuildRequires for packages in RHEL-6, this includes at least
1 noarch package which is a build dep for some of the x86_64
virtualisation tools.  But as a build dep only for x86_64 it's only in
the x86_64 repos.

> I did look at the Text::Hunspell module as an
> alternative approach but it's broken (CPAN RT#39824) and seems to be
> dead upstream (upstream doesn't know how to fix it anyway), which is a
> shame given that it's the official perl binding of hunspell.

Probably the fun game of a full rewrite required, ergh!


Mark


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]