[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fwd: [Puppet Users] Puppet 0.24.8 RPM (0.25.4 client not backwards compatible)



How can we better advertise updates like this in the future?


---------- Forwarded message ----------
From: Douglas Garstang <doug garstang gmail com>
Date: Thu, Mar 4, 2010 at 12:27 PM
Subject: [Puppet Users] Puppet 0.24.8 RPM (0.25.4 client not backwards
compatible)
To: Puppet Users <puppet-users googlegroups com>


Does anyone know where I can get the puppet 0.24.8 RPM? We had been
getting it from the public EPEL Repo, but it looks like they just
decided to upgrade the version in their repository to 0.25.4.

So... since our server is running 0.24.8, any other systems we install
from this point on end up getting 0.25 and then fail to talk to the
server.

The clients come up with...
Could not retrieve catalog from remote server: Error 405 on SERVER:
Method Not Allowed

I researched, and found out that this happens when the client is newer
than the server (or to be more specific the server is running 0.24.8
and the client is running 0.25.4)

To whoever decided not to make the client backward compatible, good one!

Doug.

--
You received this message because you are subscribed to the Google
Groups "Puppet Users" group.
To post to this group, send email to puppet-users googlegroups com 
To unsubscribe from this group, send email to
puppet-users+unsubscribe googlegroups com 
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.




-- 
Stephen J Smoogen.

Ah, but a man's reach should exceed his grasp. Or what's a heaven for?
-- Robert Browning


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]