[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: epel beta report: 20110110 changes



On Tue, 11 Jan 2011 10:12:41 -0700, Kevin wrote:

> > > > > > Broken deps for x86_64
> > > > > > ----------------------------------------------------------
> > > > > > 	1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > > > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
> > 
> > > - They added obsoletes, but not provides to the main
> > > java-1.6.0-openjdk package. 
> > 
> > Which can't be the full story, because accurate Obsoletes would have
> > prevented this broken dep already. Perhaps they've messed up the EVR
> > range of the Obsoletes tag?
> 
> $ repoquery java-1.6.0-openjdk-plugin
> java-1.6.0-openjdk-plugin-1:1.6.0.0-1.21.b17.el6.x86_64
> $ repoquery java-1.6.0-openjdk
> java-1.6.0-openjdk-1:1.6.0.0-1.31.b17.el6_0.x86_64
> $ repoquery --obsoletes java-1.6.0-openjdk
> java-1.6.0-openjdk-plugin <= 1:1.6.0.0-1.31.b17.el6_0

Hmmm, funny. Why would mash's depchecker look at an obsolete package?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]