[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EPEL6 moving from Beta to release status soon.



On Wed, 12 Jan 2011 00:08:39 +0200
Ville Skyttä <ville skytta iki fi> wrote:

> On Tuesday 11 January 2011, Kevin Fenzi wrote:
> > Greetings.
> > 
> > Just a heads up that EPEL will soon be moving it's EPEL6 branch from
> > the Beta mode (like rawhide) that it's been in to a release mode
> > (like EPEL4/5 are).
> 
> Has the "openjdk not available on ppc64" issue been resolved yet?  If
> yes, what should packagers do about it (I saw some discussion but
> don't remember seeing a definite resolution)?  If not, don't you
> think getting this resolved one way or the other would qualify as a
> release blocker?
> 
> I'd like to get new javasqlite to EPEL6 but have been waiting for
> "official" instructions how to handle missing java >= 1.6.0 on ppc64,
> and I suspect others may have stuff queued for this reason as well.

Yeah, understandable. 

My thoughts on this is that we can do: 

a) ExcludeArch: ppc64 in epel6 packages. Just not ship them for ppc64. 

b) If some kind soul or souls step up to maintain java-1.6.0-openjdk in
EPEL and build on ppc64 too, thats fine. It's going to be a lot of
work, and they should make sure to make it so it's _OLDER_ than the
RHEL6 version. Does anyone want to step up to do this? 

Note that java is very different on ppc... it's not going to be just a
'rebuild it for ppc64'. Its likely going to take some coding. 

I think we should just go with a unless someone really is willing to
work on b. 

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]