[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cherokee 1.2.1-1.el5 update breaks SSL



On Mon, Mar 21, 2011 at 21:56, Stephen John Smoogen <smooge gmail com> wrote:
>
> On Mon, Mar 21, 2011 at 08:08, Maxim Burgerhout <maxim wzzrd com> wrote:
> > Hi Pali, list,
> >
> > I'm not sure whether you are aware of this, but the recent update from
> > Cherokee to 1.2.1-1 breaks SSL on at least el5. From what I can see, it is
> > probably this bug: http://code.google.com/p/cherokee/is
> > asues/detail?id=1126.
> >
>
> Could we get some more info on this? How does it break on your side?

Of course.

A couple of days back, my box updated cherokee from EPEL from 1.0.6 to
1.2.1. When the service was restarted, Cherokee did not come up again.
The init script exited with 0, but when I requested the status from
the init script, I got 'cherokee dead, but subsys locked' error
message.

I started the admin console and tried starting Cherokee from there.
The admin interface showed me the 'libplugin_libssl.so: undefined
symbol: SSL_set_SSL_CTX' error that is mentioned in
http://code.google.com/p/cherokee/issues/detail?id=1126.

I removed 1.2.1 and reinstalled 1.0.6 from a build I downloaded from
Koji, after which Cherokee started normally again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]