[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: duplicity on EPEL4



On Tue, Oct 18, 2011 at 10:46:03PM +0200, Jérôme Benoit wrote:
> Hello, 
> 
> Is there any plan to really make it work ? 
> 
> The version shipped in EPEL 4 require subprocess (which is not present
> in python 2.3). 
> 
> I've already filled a bug report in bugzilla. 
> 
> How other python package in EPEL 4 handle subprocess requirement ? 
> So I can jump on my bug and fix the .spec file. 
> 
You can either make do without duplicity on EPEL4, change the code to not
use subprocess, or change the code to use a replacement -- for instance
pyhton-kitchen provides a compat subprocess module.

Something like:
try:
    import subprocess
except ImportError:
    from kitchen.pycompat27 import subprocess

will likely work for you.

-Toshio

Attachment: pgpDlmsT80fSt.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]