[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Proposed upgrade: python-werkzeug to 0.8.3 in EPEL 6



On Mon, Jul 02, 2012 at 01:53:39PM -0500, Ian Weller wrote:
> (re: https://fedoraproject.org/wiki/EPEL_incompatible_upgrades_policy)
> 
> Hi all,
> 
> Infrastructure is interested in using the Flask framework. I've run into
> an issue with the current version of python-werkzeug in EPEL 6.
> 
> https://github.com/mitsuhiko/flask/issues/449
> 
> Apparently, even though Flask's setup.py states it requires Werkzeug >=
> 0.6.1, upstream really meant that it requires >= 0.7. EPEL is at 0.6.2.
> 
> I would like to update Werkzeug to version 0.8.3.
> 
> Here's the full changelog from upstream:
>   http://werkzeug.pocoo.org/docs/changes/
> 
> python-werkzeug is currently orphaned in EPEL and has no dependencies.
> 
It doesn't look like there are many backwards incompatible changes (I see
mostly additions, not many changes or subtractions to the API -- a few
behaviour changes that are arguably bug fixes).

If updating the version can get this useful enough to pick up a maintainer
in EPEL, that seems useful as well.

-Toshio

Attachment: pgpAp7HI7jY0u.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]