[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Overlapping packages: Getting closer to a policy



On Fri, Jun 08, 2012 at 02:52:25PM -0400, Stephen Gallagher wrote:
> 
> For packages that overlap outside of base+optional, could we just agree
> to allow SRPM rebuilds with the exception that the EPEL release numbers
> must always be less than the official RHEL release numbers?
> 
> i.e. if we have mypackage-1.0-8.el6 in the HA channel, we can opt to
> repackage it in EPEL if-and-only-if the release number is 7.9 or lower
> (making it mypackage-1.0-7.9.el6).

That could be part of a solution but it's not all of a solution because the
packages we could get from the channels can conflict with each other
(mypackage-1.0-8.el6 might be in os, for instance, and mypackage-1.1-2.el6
might be in CloudForms.  Or myfoo-1.0-1.el6 is in ha and myfoo-2.0-1.el6 is
in RHVT).

-Toshio

Attachment: pgp0fxpscXwMG.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]