[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

incompatible upgrade to apache traffic server



I would like to upgrade Apache Traffic Server (ATS) from v3.0.x to new
stable branch v3.2.x. The 3.2 branch has lots of improvements for IPv6
and SSL that are important to me, and also fixes a crash I've been
hitting in v3.0. But, unfortunately there are a couple of incompatible
config file changes, ref:

https://cwiki.apache.org/confluence/display/TS/Upgrading+to+3.2

Only the "SSL certificate configuration" and "HTTP Quick filtering
configuration" needs to be handled by the user (if they are used). The
hostdb and stats-changes can be handled automatically during upgrade.

Will it be OK to do this upgrade in EPEL, together with an
announcement to epel-announce, or are we stuck on v3.0 ?


Highlights of this release includes:

* Over 800 commits, and 300 Jira tickets closed since v3.0.
* Several SSL improvements, including SNI (Server Name Indication) and
NPN (Next Protocol Negotiation). Overall SSL stability is also
improved.
* Full IPv6 support, v3.0 only had client side IPv6. All IP related
plugin APIs are now also IPv6 aware.
* New, flexible configurations for managing inbound and outgoing IP
addresses and ports. You can now bind any number, and combinations, of
addresses and ports for both HTTP and HTTPS.
* Range request for large objects in cache are now much (much) faster.
* Several new, and improved, plugin APIs are now available.
* Performance and stability improvements in the Cluster Cache feature.
* Much better performance when proxying to a Keep-Alive HTTP backend
server connection. Overall cache performance is also significantly
better.
* Several stable plugins are now included with the core distributions.
* Supports all gcc versions 4.1.2 and higher, Clang / LLVM 3, and the
Intel compiler suite. Builds and runs on Linux, FreeBSD, Solaris and
OSX.


  -jf


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]