[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fixing Puppet in Fedora/EPEL



On Fri, Oct 19, 2012 at 04:04:24PM -0700, Michael Stahnke wrote:
> * Move EPEL 6, Fedora >= 17 to use Puppet 3.0.

Speaking for my previous job, it would really be unfortunate to have a
non-compatible update of puppet in EPEL. Unless accompanied by very loud
trumpets and fireworks beforehand, the day that update went out would be a
very sad and busy day for a number of sysadmins.

I'm not opposed to putting puppet 3 in, but it'd really be helpful if it
went in as "puppet3" or something, and left the stable version as is,
happily getting security-only updates.

(I agree that we need to find a better solution to this long term. But
that's what we've got.)

The same _probably_ goes for F17.

And, technically, it's getting _really late_ for big changes for F18 --
the change deadline is the 26th, so we should hurry with that if possible.


> Puppet Labs release engineering is more than willing to do a majority of
> this work to make this happen.

That is awesome. I very much support getting puppet into better shape in
Fedora, and your participation is great.

-- 
Matthew Miller  ☁☁☁  Fedora Cloud Architect  ☁☁☁  <mattdm fedoraproject org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]