[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] Error compiling virt-mem-2.8



Richard W.M. Jones wrote:
On Thu, Aug 14, 2008 at 07:42:33PM +0530, M.R Niranjan  wrote:
/usr/bin/ld: cannot find -lvirt
collect2: ld returned 1 exit status
Error during linking

You have got libvirt installed, right?  If you installed libvirt on
some non-standard path then you may need to tell configure where it
is.  I think you need to do:
Yes, libvirt is already installed,

[root dhcp7-90 virt-mem-0.3.0]# rpm -q libvirt
libvirt-0.4.4-3.fc10.x86_64
libvirt-0.4.4-3.fc10.i386


  LIBS="/some/nonstandard/path" ./configure

If that doesn't work try LIBRARY_PATH instead of LIBS
which path should i specify as LIBS or LIBRARY_PATH , as the libvirt rpm installs libraries of libvirt in /usr/lib64.

Rich.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]