[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] -parallel supported?



 >|>  >|Check out
 >|>  >|http://libvirt.org/formatdomain.html#elementsConsole for
 >|>  >|xml examples.
 >|> 
 >|>  I added
 >|> 
 >|>     <parallel type='pty'>
 >|>       <source path='/dev/lp0' />
 >|>       <target port='0'/>
 >|>     </parallel>
 >|> 
 >|> to the <devices> section of the relevant file in /etc/libvirt/qemu. The
 >|> parallel "hardware" shows up in virt-manager, but with - as the source
 >|> path; running the domain yields
 >|
 >|>   libvirtError: internal error Timed out while reading console startup
 >|>   output
 >|> 
 >|> Same result if I use <source path='/dev/pts/2' />. If I remove the
 >|> parallel "hardware" in the virt-manager, the guest starts up OK.
 >|
 >|Your XML syntax is wrong. You specified a 'pty' but then gave it a
 >|real path which doesn't make sense. You want type='dev' instead,
 >|and the <target> element is redundant - that's an output only
 >|element at this time. So, eg
 >|
 >|     <parallel type='dev'>
 >|       <source path='/dev/lp0' />
 >|     </parallel>
 >|

The example syntax at the libvirt.org site I was directed to is

        <parallel type='pty'>
          <source path='/dev/pts/2'/>
          <target port='0'/>
        </parallel>

so that should be corrected if it's "wrong".

Bob T.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]