[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] Virt-Manager not connecting qemu:///system



On Fri, Sep 26, 2008 at 05:41:02PM +0200, Guido G?nther wrote:
> On Fri, Sep 26, 2008 at 09:51:26AM -0400, Cole Robinson wrote:
> > It's easy to forget, but anytime you update libvirt you will
> > need to restart libvirtd. Sounds like that could be the problem.
> The Ubuntu packages are based on the Debian ones and I dropped the
> daemon restart from the postinst so we don't tear down all running
> machines - so this is likely the problem. 
> Did anybody work on saving enough state to restart libvirtd while
> keeping the VMs running? If not I might give it a whirl once I find some
> time.

We've got this problem sorted in the 'lxc' driver and need to apply
the same approach to the QEMU driver. The problem was always finding
the Pseduo-TTY/PID for the monitor after restart, and associating the
live config with it. We've "solved" that in LXC driver by savingt the
live XML & PID to /var/run/libvirt/lxc/. It basically needs the same
approach to be applied to the QEMU daemons. In addition the DNSmasq
deamon needs adapting for simiarl reasons.


Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]