[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Lots of lost+found files ...



Hi,

I've recently had a spate of filesystem errors on my laptop which
is running a vanilla RedHat 7.2 (kernel 2.4.7) using the ext3
filesystem on all partitions.

I have been using the laptop with no apparent problems for some time
but last weekend, when I was trying to compile Evolution overnight,
I hit a compile problem; it complained that a Makefile didn't exist
in a script directory.

On investigation this directory appeared to be empty but when I tried
to copy the missing files back in I got lots of I/O errors.

To cut a long story short I ended up running fsck and got lotsa inodes
moved into lost+found and still some dodgy enteries in the directories.

That filesystem was /home, I've also had problems on /usr and / aswell
all with the same sort of symptoms - files appear to go missing and
fsck finds lots of unconnected inodes and moves them away.

I ran badblocks on the partitions affected and nothing turned up there,
also I'm running Win2000 on the machine as well and that doesn't appear
to be complianing about disk errors or anything.

I had a trawl through the ext3-users archive and found some mention
in a message from Stelian Pop, Subject: Re: ext3-2.4-0.9.4-246ac5 problem...
which seems like the same symptoms.

Are there some known problems with ext3 and RH7.2/kernel 2.4.7?
I also saw mention of issues with ext3 when the machine is under
heavy load - it was doing a fair amount of compiling.

I haven't touched the partitions since so if there is anything I
can look at to get more information let me know.

Cheers,

Andy
--
"Never trust anything that can think for itself if you can't see
 where it keeps it's brains" - Mr Weasley, "Harry Potter and the
                               Chamber of Secrets"





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]