[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EXT3-fs error..bad entry in directory



Thanks Ian.

Later that day the filesystem unsable - e2fsck attached all the files in
lost+found. The raid array was having serious issues.

Restored from tape to a big ide drive until we sort out the scsi problems.

Thanks for your input.

On Wed, 12 Dec 2001, Ian! D. Allen [NCFreeNet] wrote:

>
> >We have a RH71 machine running 2.4.16 kernel with e2fsprogs 1.25.
> >I noticed many of these errors in our logs.
> >
> >EXT3-fs error (device sd(8,1)): ext3_readdir: bad entry in directory
> >#884828: directory entry across blocks - offset=0, inode=404600689,
> >rec_len=23080, name_len=59
>
> I've seen this kind of corruption on ext2 as well.
>
> We run a 2.2.19 kernel with 3Ware Escalade RAID cards (running RAID 10),
> no ext3 (just plain ext2) and get exactly this kind of corruption.
>
> Our sda file systems get outrageous inode numbers for the errors.  When I
> decode the numbers and look at them as ASCII, I often see parts of words.
>
> Something is amiss with the SCSI disk code, I think.  I don't think
> it's an ext3 problem.
>
> --
> -IAN!  Ian! D. Allen   Ottawa, Ontario, Canada   idallen ncf ca
>        Home Page on the Ottawa FreeNet: http://www.ncf.ca/~aa610/
>        College professor at: http://www.algonquincollege.com/~alleni/
>        Board Member, TeleCommunities CANADA  http://www.tc.ca/
>
>
>
> _______________________________________________
> Ext3-users mailing list
> Ext3-users redhat com
> https://listman.redhat.com/mailman/listinfo/ext3-users
>

-- 
-----------------------------------------------------
 Jessie Bryan
 e - jbryan netlojix com
 w - www.netlojix.com
-----------------------------------------------------







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]