[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM Unpacking??



Hey there,

this isn't the place to ask, but I don't know where to ask else, so I'm
sorry:-)

Anyways I compiled the kernel 2.2.19 (2.2.18 with 2.2.19pre6 patch and
ext3 patch) and the modules I used to have under 2.2.14 also. OK make the
kernel, made the modules and did make modules_install, the kernel calls
itself 2.2.19pre6ext3 and thus the modules where installed under
/lib/modules/2.2.19pre6ext3 booting the kernel and doing uname -a will
also give 2.2.19pre6ext3 so this should be ok.

Now for the problem though
when booting my network and scsi modules won't load, it says that it can't
find a module with those names. I check in the 2.2.19's module dir but
they ARE there with the same names as they had under 2.2.14

--Don't read unless you don't mind
I'm also wondering why i need the device that makes a filesystem in RAM
needs to be included in the kernel to boot from a SCSI device while it
isn't mentioned in there, took me pretty long to figure that one
out...:-) can anyone tell me why that's required? I don't see the link
:-)
--Start reading again :-)

Oh before I forget, the modules are also in the same subdirs as they are
for the 2.2.14 kernel :-)

I'm using SuSE (sorry redhat freaks :-)) and in the scripts they will set
a var to the module dir by
var = /lib/modules/`uname -r`
and uname -r on the prompt returns: 2.2.19pre6
also doing cd /lib/modules/`uname -r` on the prompt gets me exactly where
I wanna be (/lib/modules/2.2.19pre6ext3/)

Anyone got any idea as on why my modules won't load and I get an error it
can't find it?

Kind regards,

Ferry van Steen

PS in the docs it now says to stop reading if you don't know how to patch
the kernel. You might wanna put in there that you can unpack them into the
linux kernel source directory (mostly /usr/src/linux-2.2.19 or
/usr/src/linux if the link is made correctly) and then do:
patch -p1 < patchfile
this worked with both your diff files and the 2.2.18 => 2.2.19pre6 from
alan
then again, it only took 20 secs or so to figure it out :-)

Anyways thanks for the help

Have a good one


On Wed, 31 Jan 2001, Stephen C. Tweedie wrote:

> Hi,
> 
> On Wed, Jan 31, 2001 at 11:59:05AM +0100, Freaked Personality wrote:
> > He also has a pre7 now, can I patch againt that too?
> 
> You can try, it may well work.
> 
> --Stephen
> 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]