[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ext3fs crash with lots of mmap/munmap/unlink activity



Hi all!

It seems the current ext3 code has some problems; my machine is running
2.4.6-ac1 with ext3-0.9 patches on top of it. This afternoon, I was doing
some testing of a little piece of code on my machine, and I was able to
crash it.

What this program does is, in effect something like (pseudo-code)

for(i=0; i<100; i++) {
  fd=creat file-i
  truncate fd, 50M
  mmap fd
  close fd
  fill the mmaped file-i with some 50MB of data
  munmap file-i
}
for(i=0; i<100; i++) {
  unlink file-i
}

When I run this with file-i on my ext2 partition, I'm not able to hang my
machine, if I run it on a (plain, no lvm or raid) ext3 partition, it is
quite simple to get it to crash reproducibly.

About the hardware: this is a dual P-II, with 256 MB RAM, and ide disks, of
which some are configured as raid devices.

I'm having some troubles catching the oops, either the serial port of my
laptop isn't working correctly anymore, or one of my cats has been playing
to enthousiasticly with my nullmodem cable.

Will try to fix that later, or, if that doesn't even work, write down the
oops manually etc.

Regards,
-- 
  Q_.           Jasper Spaans <j sp3r net>
 `~\            http://jsp.ds9a.nl/
Mr /\           Tel/Fax: +31-84-8749842
Zap             Move '.sig' for great justice!





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]