[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext3fs for kernel 2.4.2?



On Thu, Jul 26, 2001 at 05:46:27PM +0300, Imad Ossaily nokia com wrote:
> does anybody know if there is an ext3fs patch for kernel 2.4.2-2 that is
> shipped with redhat 7.1?
> I was abel to fins patches only for 2.4.6 and 2.4.7.
> Please try to help ASAP.
 
Your best bet is probably to upgrade to the RedHat Rawhide kernel, 2.4.6-2.4,
which uses 2.4.6-ac5 and ext3-0.9.3.  You can grab it from a mirror like
http://rpmfind.net/linux/rawhide/1.0/i386/RedHat/RPMS/

You should upgrade mkinitrd, modutils, ksymoops, losetup, mount, and e2fsprogs.
You might want to also grab lm_sensors, etc., while you are there.
I've also upgraded gcc from RawHide on my boxes.

If these won't install because of glibc dependencies, either upgrade glibc
also [ note that you can use rpmfind to resolve the dependencies for you ... ]
or grab the source rpms from http://rpmfind.net/linux/rawhide/1.0/SRPMS/SRPMS
and rebuild.

You can apply a 0.9.3 -> 0.9.4 patch (generated from CVS) on top of the
kernel source, or insert it as an additional patch into the source rpm,
rebuild, and install.  The Redhat developers will no doubt put out another
kernel in the near future with the latest ext3 fixes.

Regards,

   Bill Rugolsky





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]