[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Mounting / as ext3 when ext3 is modularized in 2.4



Hello,

I recently switched from 2.2 to 2.4 kernel. Each partition already contains
a journal. I tried kernel-2.4.5-0.2.9 from RedHat Rawhide, where ext3/jbd is
modularized. For the people who want to try this kernel, you first need to
rebuild it, and enable CONFIG_JBD_DEBUG. This solves an unresolved symbol
in jbd.o which prevents ext3 to load. (This issue will be solved in next 
RawHide)

My question is on how to tell the kernel to mount the real root partion
as ext3, when you load the ext3 module in the initrd ?

RAMDISK: Compressed image found at block 0
Freeing initrd memory: 300k freed
VFS: Mounted root (ext2 filesystem).
Loading jbd module
Journalled Block Device driver loaded
Loading ext3 module
VFS: Mounted root (ext2 filesystem) readonly.    <--- ?? not ext3 ?
change_root: old root has d_count=2
Trying to unmount old root ... okay
Freeing unused kernel memory: 224k freed
Adding Swap: 385520k swap-space (priority -1)

-- 
Fab





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]