[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Software RAID & Ext3 v0.0.6b



Alan Hourihane wrote:
> 
> I've just set up a brand new system with software raid1 (in degraded mode)
> with one IDE 20GB drive, using kernel 2.2.19pre16 with ext3 0.0.6b.
> 
> It's split like this..
> 
> 32MB /dev/hda1 /boot
> 2GB /dev/hda2 /
> ~18GB /dev/hda3 /home
> 
> all partitions are marked as 0xfd (autostart raid) with the patches from
> http://people.redhat.com/mingo/raid-patches for 2.2.17. And I've made all the
> ext3 filesystems with the -j option to create a hidden journal file.
> 
> Everything works great !
> 
> But. When I plug the second disk in a start a reconstruction, sooner or later
> within seconds I get an 'ASSERT' failure at line 411 in journal.c. !

As far as I know it's a big no-no to run _any_ journalled filesystem on
software raid. The same is true for swap partitions: you get in major
trouble in case of rebuilding the raid array with your swap on it. 2.4.x
should be o.k though.
I'm not that sure about the actual reason(s), but I'm sure someone else
(Stephen at least) can give you a more detailed statement...

Juri

-- 
juri haberland innominate com
system engineer                                         innominate AG
clustering & security                            the linux architects
tel: +49-30-308806-0    fax: -77            http://www.innominate.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]