[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ext3 filesystem lost.



Hello.

We have, over the last few months, lost ext3 filesystems three times.
The whole filesystem left unusable. 

nfs-server:~# mount /dev/rd/c0d1p1 /mnt -t ext3
mount: wrong fs type, bad option, bad superblock on /dev/rd/c0d1p1,
       or too many mounted file systems

(in dmesg)
EXT3-fs: journal inode is deleted.
EXT3-fs: get root inode failed

nfs-server:~# fsck /dev/rd/c0d1p1
Parallelizing fsck version 1.18 (11-Nov-1999)
e2fsck 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
fsck.ext2: Filesystem has unsupported feature(s) while trying to open /dev/rd/c0d1p1

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

I tried with alternate superblocks. 

This happend whilst booting our NFS-server. It hanged while umounting
its filesystems. We tried to remount the filesysem in question
read-only, but this hanged as well. When the filesystem came back up,
the filesystem was gone. The rest of the disk (the partition table) was
still healthy. 

We are running 2.2.19 with ext3-0.0.6b and the Openwall-patch[1]. Debian
potato R3. Ordered mode journaling.


Ideas?

-- 
Per Andreas Buer

[1]: This has happend before - without the openwall-patch.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]