[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ext3fs and 2.4.14 kernel



Good morning,

I have tried to compile a 2.4.14 kernel (because I have some trouble with the framebuffer and my Toshiba...). Thus, I have downloaded the latest kernel and the ext3 patch. I have used the .config file used for the compilation of my 2.4.13 kernel, but the compilation ends with

make[1]: Quitte le répertoire `/usr/src/linux-2.4.14/arch/i386/lib'
ld -m elf_i386 -T /usr/src/linux-2.4.14/arch/i386/vmlinux.lds -e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o \
--start-group \
arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o \
drivers/acpi/acpi.o drivers/parport/driver.o drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o drivers/media/media.o drivers/ide/idedriver.o drivers/scsi/scsidrv.o drivers/cdrom/driver.o drivers/sound/sounddrivers.o drivers/pci/driver.o drivers/pcmcia/pcmcia.o drivers/net/pcmcia/pcmcia_net.o drivers/char/pcmcia/pcmcia_char.o drivers/video/video.o drivers/usb/usbdrv.o drivers/net/irda/irda.o \
net/network.o \
/usr/src/linux-2.4.14/arch/i386/lib/lib.a /usr/src/linux-2.4.14/lib/lib.a /usr/src/linux-2.4.14/arch/i386/lib/lib.a \
--end-group \
-o vmlinux
drivers/block/block.o: In function `lo_send':
drivers/block/block.o(.text+0x905a): undefined reference to `deactivate_page'
drivers/block/block.o(.text+0x9117): undefined reference to `deactivate_page'
make: *** [vmlinux] Erreur 1


I don't know if the trouble comes from the kernel itself or the patch. I have tried to find the deactivate_page, but this function does not seem to be define ! Any idea ?

Thank you for your help,

JKB





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]