[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kernel 2.4.19 ext3 Problem




> Something seems to be stripping the attachment.  Probably best to
> send the text inline.

Other way around - I had sent it inline - this time I've included
it as an attachment

Thx, R
>From - Sun Aug 04 17:50:06 2002
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Message-ID: <3D4DCBBD 3040805 bayarea net>
Date: Sun, 04 Aug 2002 17:50:05 -0700
From: Randy Broman <rbroman bayarea net>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508 Netscape6/6.2.3
X-Accept-Language: en-us
MIME-Version: 1.0
To: Ext3-users redhat com
Subject: Kernel 2.4.19 ext3 Problem
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

My system is RH7.2 with custom 2.4.18 or 2.4.19 kernel(s), downloaded
from kernel.org. My root filesystem is ext3 on ataraid. I'm using initrd.

My system comes up fine with 2.4.18 kernel, but when trying to boot
a new 2.4.19 kernel I get the following sequence:




creating root device
mounting root filesystem
mount: error 22 mounting ext3


kernel panic: no init found....

Before compiling my new 2.4.19 kernel, I copied my 2.4.18 .config
file to the the 2.4.19 .config, did a make xconfig and made *no*
configuration changes, just saved the result. I put the diff between
the 2.4.18 and 2.4.19 .config files below - there's a lot of differences
and maybe I *need* to make some changes in the configuration, but I'm
not sure what they are.

My /etc/fstab is also below. Ideas appreciated as to what's wrong.

Randy
------------------------------------------------
[root jboat5 boot] # cat /etc/fstab
/dev/ataraid/d0p7    /                       ext3    defaults        1 1
/dev/ataraid/d0p1    /boot                   ext3    defaults        1 2
none                 /dev/pts                devpts  gid=5,mode=620  0 0
/dev/ataraid/d0p5    /home                   ext3    defaults        1 2
none                 /proc                   proc    defaults        0 0
none                 /dev/shm                tmpfs   defaults        0 0
/dev/ataraid/d0p6    /usr                    ext3    defaults        1 2
/dev/ataraid/d0p9    /var                    ext3    defaults        1 2
/dev/ataraid/d0p8    swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 
noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    
noauto,owner,kudzu 0 0

------------------------------------------------
[root jboat5 boot]# diff  Config-2.4.18test11 Config-2.4.19test1
2c2
< # Automatically generated by make menuconfig: don't edit
---
 > # Automatically generated make config: don't edit
53a54
 > # CONFIG_X86_MCE is not set
94,95d94
< # CONFIG_HOTPLUG_PCI_COMPAQ is not set
< # CONFIG_HOTPLUG_PCI_COMPAQ_NVRAM is not set
129d127
< # CONFIG_PARIDE is not set
132a131
 > # CONFIG_BLK_DEV_UMEM is not set
143,149d141
< # CONFIG_BLK_DEV_MD is not set
< # CONFIG_MD_LINEAR is not set
< # CONFIG_MD_RAID0 is not set
< # CONFIG_MD_RAID1 is not set
< # CONFIG_MD_RAID5 is not set
< # CONFIG_MD_MULTIPATH is not set
< # CONFIG_BLK_DEV_LVM is not set
172a165,168
 >
 > #
 > # > #
174a171,174
 >
 > #
 > # Appletalk devices
 > #
191a192,196
 > # Network testing
 > #
 > # CONFIG_NET_PKTGEN is not set
 >
 > #
195,196d199
< # CONFIG_PHONE_IXJ is not set
< # CONFIG_PHONE_IXJ_PCMCIA is not set
206a210,213
 >
 > #
 > # Please see Documentation/ide.txt for help/info on IDE drives
 > #
210a218
 > # CONFIG_IDEDISK_STROKE is not set
212,217d219
< # CONFIG_BLK_DEV_IDEDISK_FUJITSU is not set
< # CONFIG_BLK_DEV_IDEDISK_IBM is not set
< # CONFIG_BLK_DEV_IDEDISK_MAXTOR is not set
< # CONFIG_BLK_DEV_IDEDISK_QUANTUM is not set
< # CONFIG_BLK_DEV_IDEDISK_SEAGATE is not set
< # CONFIG_BLK_DEV_IDEDISK_WD is not set
219,220d220
< # CONFIG_BLK_DEV_TIVO is not set
< # CONFIG_BLK_DEV_IDECS is not set
224a225,229
 > # CONFIG_IDE_TASK_IOCTL is not set
 >
 > #
 > # IDE chipset support/bugfixes
 > #
227d231
< # CONFIG_BLK_DEV_ISAPNP is not set
232d235
< CONFIG_BLK_DEV_ADMA=y
233a237
 > # CONFIG_BLK_DEV_IDEDMA_FORCED is not set
234a239
 > # CONFIG_IDEDMA_ONLYDISK is not set
237c242
< # CONFIG_IDEDMA_NEW_DRIVE_LISTINGS is not set
---
 > CONFIG_BLK_DEV_ADMA=y
239d243
< # CONFIG_AEC62XX_TUNING is not set
241d244
< # CONFIG_WDC_ALI15X3 is not set
243d245
< # CONFIG_AMD74XX_OVERRIDE is not set
248d249
< # CONFIG_HPT34X_AUTODMA is not set
274a276,279
 >
 > #
 > # SCSI support type (disk, tape, CD-ROM)
 > #
282a288,291
 >
 > #
 > # Some SCSI devices (e.g. CD jukebox) support multiple LUNs
 > #
393d401
< # CONFIG_SUNLANCE is not set
395,396d402
< # CONFIG_SUNBMAC is not set
< # CONFIG_SUNQE is not set
405,406d410
< # CONFIG_ELMC is not set
< # CONFIG_ELMC_II is not set
423d426
< # CONFIG_MYRI_SBUS is not set
427a431
 > # CONFIG_TIGON3 is not set
430d433
< # CONFIG_PLIP is not set
433d435
< # CONFIG_PPP_FILTER is not set
510d511
< # CONFIG_I2C_PHILIPSPAR is not set
524a526
 > # CONFIG_MK712_MOUSE is not set
530,534d531
< # CONFIG_INPUT_NS558 is not set
< # CONFIG_INPUT_LIGHTNING is not set
< # CONFIG_INPUT_PCIGAME is not set
< # CONFIG_INPUT_CS461X is not set
< # CONFIG_INPUT_EMU10K1 is not set
536,545c533,536
< # CONFIG_INPUT_SERPORT is not set
< # CONFIG_INPUT_ANALOG is not set
< # CONFIG_INPUT_A3D is not set
< # CONFIG_INPUT_ADI is not set
< # CONFIG_INPUT_COBRA is not set
< # CONFIG_INPUT_GF2K is not set
< # CONFIG_INPUT_GRIP is not set
< # CONFIG_INPUT_INTERACT is not set
< # CONFIG_INPUT_TMDC is not set
< # CONFIG_INPUT_SIDEWINDER is not set
---
 >
 > #
 > # Joysticks
 > #
547,555d537
< # CONFIG_INPUT_IFORCE_232 is not set
< # CONFIG_INPUT_WARRIOR is not set
< # CONFIG_INPUT_MAGELLAN is not set
< # CONFIG_INPUT_SPACEORB is not set
< # CONFIG_INPUT_SPACEBALL is not set
< # CONFIG_INPUT_STINGER is not set
< # CONFIG_INPUT_DB9 is not set
< # CONFIG_INPUT_GAMECON is not set
< # CONFIG_INPUT_TURBOGRAFX is not set
561a544
 > # CONFIG_AMD_RNG is not set
594c577,580
< # CONFIG_I2C_PARPORT is not set
---
 >
 > #
 > # Video Adapters
 > #
606d591
< # CONFIG_VIDEO_MEYE is not set
619,620d603
< # CONFIG_RADIO_MIROPCM20 is not set
< # CONFIG_RADIO_MIROPCM20_RDS is not set
634,635d616
< # CONFIG_REISERFS_CHECK is not set
< # CONFIG_REISERFS_PROC_INFO is not set
637d617
< # CONFIG_ADFS_FS_RW is not set
649,650d628
< # CONFIG_JFFS_FS is not set
< # CONFIG_JFFS2_FS is not set
653c631
< # CONFIG_RAMFS is not set
---
 > CONFIG_RAMFS=y
660d637
< # CONFIG_NTFS_RW is not set
664,665d640
< # CONFIG_DEVFS_MOUNT is not set
< # CONFIG_DEVFS_DEBUG is not set
668d642
< # CONFIG_QNX4FS_RW is not set
684d657
< # CONFIG_ROOT_NFS is not set
694,701d666
< # CONFIG_NCPFS_PACKET_SIGNING is not set
< # CONFIG_NCPFS_IOCTL_LOCKING is not set
< # CONFIG_NCPFS_STRONG is not set
< # CONFIG_NCPFS_NFS_NS is not set
< # CONFIG_NCPFS_OS2_NS is not set
< # CONFIG_NCPFS_SMALLDOS is not set
< # CONFIG_NCPFS_NLS is not set
< # CONFIG_NCPFS_EXTRAS is not set
783a749
 > # CONFIG_SOUND_BT878 is not set
785a752,754
 > # CONFIG_MIDI_EMU10K1 is not set
 > # CONFIG_SOUND_FUSION is not set
 > # CONFIG_SOUND_CS4281 is not set
789a759,761
 > # CONFIG_SOUND_MAESTRO3 is not set
 > # CONFIG_SOUND_ICH is not set
 > # CONFIG_SOUND_RME96XX is not set
794a767
 > # CONFIG_MIDI_VIA82CXXX is not set
805d777
< # CONFIG_SOUND_ICH is not set
813d784
< # CONFIG_PAS_JOYSTICK is not set
815d785
< # CONFIG_SOUND_SOFTOSS is not set
822a793
 > # CONFIG_SOUND_YMFPCI is not set
824a796
 > # CONFIG_SOUND_TVMIXER is not set
830a803,806
 >
 > #
 > # Miscellaneous USB options
 > #
833a810,814
 >
 > #
 > # USB Host Controller Drivers
 > #
 > # CONFIG_USB_EHCI_HCD is not set
836a818,821
 >
 > #
 > # USB Device Class drivers
 > #
849a835,838
 >
 > #
 > # USB Human Interface Devices (HID)
 > #
850a840
 > # CONFIG_USB_HIDINPUT is not set
852a843,846
 >
 > #
 > # USB Imaging devices
 > #
857a852,855
 >
 > #
 > # USB Multimedia devices
 > #
865a864,867
 >
 > #
 > # USB Network adaptors
 > #
866a869
 > # CONFIG_USB_RTL8150 is not set
871c874,877
< # CONFIG_USB_USS720 is not set
---
 >
 > #
 > # USB port drivers
 > #
889,896d894
< # CONFIG_USB_SERIAL_KEYSPAN_USA28 is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA28X is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA28XA is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA28XB is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA19 is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA18X is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA19W is not set
< # CONFIG_USB_SERIAL_KEYSPAN_USA49W is not set
902a901,904
 >
 > #
 > # USB Miscellaneous drivers
 > #
903a906,907
 > # CONFIG_USB_AUERSWALD is not set
 > # CONFIG_USB_BRLVGER is not set







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]